VCOM:VectorWorks:ISDK::GetMesh

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace

Member of VCOM:VectorWorks:ISDK

GetMesh only works for kMeshNode objects. It doesn't work for solids.

virtual bool VCOM_CALLTYPE GetMesh(
MCObjectHandle hMesh,
IMeshData** outMeshData) = 0;

Parameters

hMesh MCObjectHandle A handle of kMeshNode objects
outMeshData IMeshData** no info.

Example

// meshH is a handle of kMeshNode objects
Handle meshH;

...

VectorWorks::IMeshDataPtr	thisMesh;
bool isGetMesh = gSDK->GetMesh( meshH, & thisMesh );

Version

Availability: from Vectorworks 2015