VCOM:VectorWorks:ISDK::GetMarkerPopupSelectedItem

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

      • Note: This function is obsolete; please use 'Set/GetMarkerChoice()'


Returns the 1-based index number of the selected item in the specified marker popup menu item. If the return value equals 8, a custom marker is selected, and the style angle, and size parameters will describe the marker.

virtual short GetMarkerPopupSelectedItem(
long dialogID,
long componentID,
char& style,
char& angle,
short& size)

Parameters

long dialogID No information available.
long componentID No information available.
char& style No information available.
char& angle No information available.
short& size No information available.

Return Value

On error returns: -1

Version

Availability: from Vectorworks 2009