VCOM:VectorWorks:ISDK::GetMarker

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the markers of a passed segment or arc. This function supercedes GetArrowHeads. Each size unit is equal to 1/16384 of an inch on the printed page. If you have a segment or arc with a one inch marker, size will return with 16384. If you pass NIL for the obj parameter, this call will get the marker defaults for this document.

virtual void GetMarker(
MCObjectHandle obj,
MarkerType& style,
short& size,
short& angle,
bool& start,
bool& end)

Parameters

MCObjectHandle obj No information available.
MarkerType& style No information available.
short& size No information available.
short& angle No information available.
bool& start No information available.
bool& end No information available.

Version

Availability: from Vectorworks 2009