VCOM:VectorWorks:ISDK::GetLocalizedPluginName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the localized name of a plug-in given its universal name.


When VectorWorks plug-ins are localized by distributors in other countries, their names are translated to the appropriate language. The plug-in file stores both the original universal name and this translated localized name. The translated name is displayed by the VectorWorks user interface instead of the original name. If a script needs to display the name of a plug-in in a dialog or message then it should call this function to determine the localized name. (Note that scripts will use the universal name to specify a plug-in when the name is not being displayed to the user.)

virtual bool GetLocalizedPluginName(
const InternalName pluginName,
InternalName localizedName)

Parameters

constInternalName pluginName No information available.
InternalName localizedName No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009