VCOM:VectorWorks:ISDK::GetLayerForStory

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace

Member of VCOM:VectorWorks:ISDK

Returns the layer on the indicated story that has the specified level type. If there is no layer on the story with that level type, nil is returned.

virtual MCObjectHandleVCOM_CALLTYPE GetLayerForStory(
MCObjectHandle story,
const TXString& layerLevelType) = 0;

Parameters

story MCObjectHandle The story of the requested layer.
layerLevelType const SDK:TXString& The level type of the requested layer.

Version

Availability: from Vectorworks 2012