VCOM:VectorWorks:ISDK::GetGradientData

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the spot position, midpoint position and color of the specified gradient segment.

virtual bool GetGradientData(
MCObjectHandle gradient,
short segmentIndex,
double& spotPosition,
double& midpointPosition,
WorldPt3& color)

Parameters

MCObjectHandle gradient No information available.
short segmentIndex No information available.
double& spotPosition No information available.
double& midpointPosition No information available.
WorldPt3& color No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009