VCOM:VectorWorks:ISDK::GetFilePathInStandardFolder

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the first file in the search path with the given name. If the file is not found, the path will be under the User Data folder, ready to be created.

folderClass: One of the folderSpecifier constants defined in FolderSpecifiers.h

fileName: the name of the file to search for.

outFilePath: The path of the file that was found.

NOTE: This function is obsolete. Use GetFilePathInStandardFolderN instead.

virtual bool GetFilePathInStandardFolder(
long folderClass,
const char fileName[255],
char outFilePath[255],
bool& exists)

Parameters

long folderClass No information available.
constchar fileName[255] No information available.
char outFilePath[255] No information available.
bool& exists No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009