VCOM:VectorWorks:ISDK::GetDimensionStandardVariable

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns a property of a dimension standard. The index specifies which dimension to examine. The nine built-in dimension standards use indexes 1 thru 9. Custom dimensions use indexes 0 thru -8. The selector chooses which property will be returned, and the value contains the actual value of that property. This function returns false if an invalid dimension index or field selector is specified.

virtual bool GetDimensionStandardVariable(
short dimensionIndex,
short fieldSelector,
TVariableBlock& value)

Parameters

short dimensionIndex No information available.
short fieldSelector No information available.
TVariableBlock& value No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009