VCOM:VectorWorks:ISDK::GetDLComponentPenColors

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the fore and back colors of the left and right side pens of component at index in the Double Line Preferences.

virtual CBbool GetDLComponentPenColors(
Sint16 index,
ColorRef &leftPenForeColor,
ColorRef &leftPenBackColor,
ColorRef &rightPenForeColor,
ColorRef &rightPenBackColor)

Parameters

Sint16 index No information available.
ColorRef &leftPenForeColor No information available.
ColorRef &leftPenBackColor No information available.
ColorRef &rightPenForeColor No information available.
ColorRef &rightPenBackColor No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009