VCOM:VectorWorks:ISDK::GetCoreWallComponent

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the core wall component of an object.

virtual short VCOM_CALLTYPE GetCoreWallComponent(
MCObjectHandle object) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Return Value

The index of the core wall component. If it is 0, there is no core wall component.

Version

Availability: from Vectorworks 2010