VCOM:VectorWorks:ISDK::GetComponentPenStyles

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the left and right side pen styles of a component in an object.

virtual Boolean VCOM_CALLTYPE GetComponentPenStyles(
MCObjectHandle object,
short componentIndex,
Sint8& leftPenStyle,
Sint8& rightPenStyle) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
leftPenStyle Sint8& Returns the pen style of the component's left line. Positive values for patterns, negative values for dash styles.
rightPenStyle Sint8& Returns the pen style of the component's right line. Positive values for patterns, negative values for dash styles.

Version

Availability: from Vectorworks 2009