VCOM:VectorWorks:ISDK::GetComponentPenColors

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the colors of the pens of a component in an object.

virtual Boolean VCOM_CALLTYPE GetComponentPenColors(
MCObjectHandle object,
short componentIndex,
ColorRef& leftPenForeColor,
ColorRef& leftPenBackColor,
ColorRef& rightPenForeColor,
ColorRef& rightPenBackColor) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.
leftPenForeColor ColorRef& Returns the fore color of the left pen.
leftPenBackColor ColorRef& Returns the back color of the left pen.
rightPenForeColor ColorRef& Returns the fore color of the right pen.
rightPenBackColor ColorRef& Returns the back color of the right pen.

Version

Availability: from Vectorworks 2009