VCOM:VectorWorks:ISDK::GetComponentNetArea

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the net area of a component in an object.

virtual WorldCoord VCOM_CALLTYPE GetComponentNetArea(
MCObjectHandle object,
short componentIndex) = 0;

Parameters

object MCObjectHandle The object. Can be a wall, round wall, slab, Wall Style, Slab Style, the Wall Preferences, or the Slab Preferences.
componentIndex short The index of the component.

Return Value

The net area of the component.

Version

Availability: from Vectorworks 2010