VCOM:VectorWorks:ISDK::GetClosestSide

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the indices of the vertices of the specified object that define the side of the object that is closest to the specified location. This function only supports 2D objects. If the object is not supported, it will return -1 and -1.

virtual void GetClosestSide(
MCObjectHandle obj,
const WorldPt& pt,
short& indexA,
short& indexB)

Parameters

MCObjectHandle obj No information available.
constWorldPt& pt No information available.
short& indexA No information available.
short& indexB No information available.

Version

Availability: from Vectorworks 2009