VCOM:VectorWorks:ISDK::GetClosestPt

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the vertex index of the object or a subobject closest to the location in index. Index is set to 0 if no vertex is close or to -1 if the type of the object is unsupported. If the object is a wall, and a vertex of a subobject is close to the location, it will set obj to that subobject. If the object is a symbol or PIO, and a vertex of a subobject is close to the location, it will return an index into the objects list to indicate which subobject in containedObj. This only supports 2D objects.

virtual void GetClosestPt(
MCObjectHandle& obj,
const WorldPt& pt,
short& index,
long& containedObj)

Parameters

MCObjectHandle& obj No information available.
constWorldPt& pt No information available.
short& index No information available.
long& containedObj No information available.

Version

Availability: from Vectorworks 2009