VCOM:VectorWorks:ISDK::GetBinaryConstraint

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns a handle to a constraint involving two objects of the specified type on the specified vertices of the specified objects. If the constraint does not exist, it returns 0.

virtual MCObjectHandle GetBinaryConstraint(
short type,
MCObjectHandle obj1,
MCObjectHandle obj2,
short obj1VertexA,
short obj1VertexB,
short obj2VertexA,
short obj2VertexB,
long containedObj1,
long containedObj2)

Parameters

short type No information available.
MCObjectHandle obj1 No information available.
MCObjectHandle obj2 No information available.
short obj1VertexA No information available.
short obj1VertexB No information available.
short obj2VertexA No information available.
short obj2VertexB No information available.
long containedObj1 No information available.
long containedObj2 No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009