VCOM:VectorWorks:ISDK::GetArrowHeadsN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the arrow head settings for the object h. starting is true if its startpt has an arrowHead, ending is true if its endpt has an arrowHead, and ArrowType is one of arArrow, arTightArrow, arBall, arSlash, arCross which correspond to MiniCAD's arrowHeads as displayed in the attribute pop-up. Size is in inches.

virtual void GetArrowHeadsN(
MCObjectHandle h,
bool& starting,
bool& ending,
ArrowType& style,
double_gs& size)

Parameters

MCObjectHandle h No information available.
bool& starting No information available.
bool& ending No information available.
ArrowType& style No information available.
double_gs& size No information available.

Version

Availability: from Vectorworks 2009