VCOM:VectorWorks:ISDK::GetArcInfoN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Returns the startAngle, sweepAngle, and center of the specified arc. The center is especially useful because the CoordRect returned from GetBoundingBox is the union of each quadrant box that the arc includes, so the center of that box is not always the center of the arc.

virtual void GetArcInfoN(
MCObjectHandle h,
double_gs& startAngle,
double_gs& sweepAngle,
WorldPt& center,
WorldCoord& radiusX,
WorldCoord& radiusY)

Parameters

MCObjectHandle h No information available.
double_gs& startAngle No information available.
double_gs& sweepAngle No information available.
WorldPt& center No information available.
WorldCoord& radiusX No information available.
WorldCoord& radiusY No information available.

Version

Availability: from Vectorworks 2009