VCOM:VectorWorks:ISDK::Get3DVertex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets vertex to the vertexNum'th vertex of the 3D polygon. Vertices are numbered starting from 1 up to CountVertices(h). If vertexNum is outside the defined range or if h is not a 3D polygon, Get3DVertex will return the point {0, 0, 0}.

virtual void Get3DVertex(
MCObjectHandle h,
short vertexNum,
WorldPt3& vertex)

Parameters

MCObjectHandle h No information available.
short vertexNum No information available.
WorldPt3& vertex No information available.

Version

Availability: from Vectorworks 2009