VCOM:VectorWorks:ISDK::GSGetResource

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Retrieves a resource specified by type and id from the external's .rsr file or MiniCAD's .rsr file. If lookOnlyInCurrentFile is true, then the call will look only in your external's .rsr file, otherwise the call will first look in your external's .rsr file and then in MiniCAD's .rsr file for the requested resource. You are strongly discouraged from passing false in the final boolean parameter. Resources in the MiniCAD application are not documented and may change without notice. The final parameter may disappear in future versions of the SDK.


Be aware that this function returns a GSHandle containing the resource requested. You must call ReleaseResource with the handle when you are done using the data, and you can pass this handle to any SDK function of class Memory Allocation except DisposeHandle.

virtual GSHandle GSGetResource(
OSType type,
short id,
bool lookOnlyInCurrentFile = true)

Parameters

OSType type No information available.
short id No information available.
boollookOnlyInCurrentFile= true No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009