VCOM:VectorWorks:ISDK::ForEachPolyEdge

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This iterates through each edge of a polyline and returns information about it - defining points, edge type, and visibility. Each edge type will be one of: kSegment, kArc, or kBezier. Cubic vertices are converted to bezier, and arc vertices may be converted into separate kSegment and kArc. Arcs are always counterclockwise. Some edges may be degenerate (have all defining points equal to each other). Warning: there may be more edges than vertices. See GS_ForEachPolyEdgeProcPtr in MiniCadCallBacks.h for more info.

virtual void ForEachPolyEdge(
MCObjectHandle inPolyH,
GS_ForEachPolyEdgeProcPtr inProc,
void* inEnv)

Parameters

MCObjectHandle inPolyH No information available.
GS_ForEachPolyEdgeProcPtr inProc No information available.
void* inEnv No information available.

Version

Availability: from Vectorworks 2009