VCOM:VectorWorks:ISDK::FindFileInPluginFolderN

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Searches for a file in all plug-in folders. fileName is the name of the file to search; if fileName has no file extension, it is assumed to be the base name of a plug-in, and the function will search for files with that base name and extensions of 'vsm', 'vst', 'vso', 'vlb', 'dll', 'sdo', and 'qtr'. The path of the file is returned in outFilePath. The function returns true if the file is found, false otherwise.

virtual bool FindFileInPluginFolderN(
char* fileName,
char outFullPath[1024])

Parameters

char* fileName No information available.
char outFullPath[1024] No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009