VCOM:VectorWorks:ISDK::ExtendNurbsCurve

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Extends a curve by a given distance at the start or the end. The extension can either be linear or can match the curvature of the existing end.

virtual MCObjectHandle ExtendNurbsCurve(
MCObjectHandle curveHandle,
double_param distance,
bool bStart,
bool bLinear)

Parameters

MCObjectHandle curveHandle No information available.
double_param distance No information available.
bool bStart No information available.
bool bLinear No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009