VCOM:VectorWorks:ISDK::DeleteVertex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Deletes the vertexNum'th vertex from h. h may be a polygon, polyline, or 3D polygon. If h has only 3 vertices, then DeleteVertex has no effect - i.e., DeleteVertex will not allow you to make a degenerate polygon.

virtual void DeleteVertex(
MCObjectHandle h,
short vertexNum)

Parameters

MCObjectHandle h No information available.
short vertexNum No information available.

Version

Availability: from Vectorworks 2009