VCOM:VectorWorks:ISDK::DeleteObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Deletes h and all of its sub-objects, if it has any. If undo is active and an undo swap primitive has been created using the AddBeforeSwapObject call, then the useUndo flag must be set to true so that object will not be freed from memory (since the undo table is pointing to it). On the other hand, if h is a temporary object and AddAfterSwapObject was not called after it was created and AddBeforeSwapObject was not called before this delete call, then the useUndo flag should be set to false so that h will actually be deleted. Note that this function does not add anything to or directly affect the undo table.

virtual void DeleteObject(
MCObjectHandle h,
bool useUndo = true)

Parameters

MCObjectHandle h No information available.
booluseUndo= true No information available.

Version

Availability: from Vectorworks 2009