VCOM:VectorWorks:ISDK::CustomBatchConvert

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This function is used to batch convert files in a folder and save converted files in another folder.

virtual voidVCOM_CALLTYPE CustomBatchConvert(
ICustomBatchConvertParams* params) = 0;

"params" is an interface inherited from ICustomBatchConvtParams. There are five pure virtual functions requiring implementation.

  1. bool ShouldOpenFileForConvert(const TXString& path);
  2. void ConvertFile(const TXString& path);
  3. void GetSourceFolder(IFolderIdentifier** srcFolder);
  4. void GetDestinationFolder(IFolderIdentifier** dstFolder);
  5. bool ShouldWriteLogFile();

Parameters

params ICustomBatchConvertParams*

Version

Availability: from Vectorworks 2013