VCOM:VectorWorks:ISDK::CreateSymbolDisplayControl

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a Layout Manager control to display the specified symbol based on the parameters given. To show a blank SymbolDisplay control, use an empty string as the symbolRefIn parameter.

virtual void CreateSymbolDisplayControl(
long dialogIDIn,
long itemIDIn,
const InternalName symbolRefIn,
short heightIn,
short widthIn,
short marginIn,
short renderModeIn,
short standardViewIn)

Parameters

long dialogIDIn No information available.
long itemIDIn No information available.
constInternalName symbolRefIn No information available.
short heightIn No information available.
short widthIn No information available.
short marginIn No information available.
short renderModeIn No information available.
short standardViewIn No information available.

Version

Availability: from Vectorworks 2009