VCOM:VectorWorks:ISDK::CreateStoryLayerTemplate

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace

Member of VCOM:VectorWorks:ISDK

Creates a new default story layer with the specified information.

virtual boolVCOM_CALLTYPE CreateStoryLayerTemplate(
TXString& name,
double scaleFactor,
TXString& layerLevelType,
WorldCoord elevationOffset,
WorldCoord defaultWallHeight,
short& index) = 0;

Parameters

name SDK:TXString& The name of the new default story layer.
scaleFactor double The scaleFactor of the new default story layer. If a scale of 1:50 is desired, pass in a scaleFactor of 50.
layerLevelType SDK:TXString& The level type of the new default story layer.
elevationOffset WorldCoord The elevation of the new default story layer.
defaultWallHeight WorldCoord The wall height of the new default story layer.
index short& This output parameter returns the index of the new default story layer.

Version

Availability: from Vectorworks 2012