VCOM:VectorWorks:ISDK::CreateResizableLayout

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Similar to CreateLayout, but creates a resizable dialog. The parameters are the same as CreateLayout except for widthResizable, and heightResizable, which specify whether the width and height, respectively, will be resizable in the resulting dialog. A dialog ID is returned by the function.

virtual long CreateResizableLayout(
const TXString& dialogTitle,
bool hasHelp,
const TXString& defaultButtonName,
const TXString& cancelButtonName,
CBbool widthResizable,
CBbool heightResizable)

Parameters

constTXString& dialogTitle No information available.
bool hasHelp No information available.
constTXString& defaultButtonName No information available.
constTXString& cancelButtonName No information available.
CBbool widthResizable No information available.
CBbool heightResizable No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009