VCOM:VectorWorks:ISDK::CreatePolyshape

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a new polygon object with no vertices. This routine is used to create both polygons and polylines: CreatePolyshape creates a polygon, then AddVertex and InsertVertex will turn it into a polyline if asked to add a non-corner vertex.

virtual MCObjectHandle CreatePolyshape( )

Parameters

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009