VCOM:VectorWorks:ISDK::CreateLinearDimension

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a linear dimension object. p1 and p2 are the two endpoints of the distance to be measured. startOffset is the distance from p1 to the dimension line. textOffset is CURRENTLY UNUSED. dir is the normalized difference between p2 and p1. If dir is passed in as (0,0), this value is calculated automatically. dimType indicates whether to allow only horizontal and vertical dimension lines, whether to rotate the dimension line to have the same direction as the vector between p1 and p2, or whether to create an ordinate dimension.

virtual MCObjectHandle CreateLinearDimension(
const WorldPt& p1,
const WorldPt& p2,
WorldCoord startOffset,
WorldCoord textOffset,
const Vector2& dir,
short dimType)

Parameters

constWorldPt& p1 No information available.
constWorldPt& p2 No information available.
WorldCoord startOffset No information available.
WorldCoord textOffset No information available.
constVector2& dir No information available.
short dimType No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009