VCOM:VectorWorks:ISDK::CreateInterpolatedSurface

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates an interpolated surface with the specified degrees and number of points. If a handle to a NURBS surface is provided,the interpolated surface will approximate that surface;if the handle is NULL, it creates a rectangular surface.numUPts(numVPts) must be greater than uDegree(vDegree).

virtual MCObjectHandle CreateInterpolatedSurface(
MCObjectHandle surfaceHandle,
long numUPts,
long numVPts,
short uDegree,
short vDegree)

Parameters

MCObjectHandle surfaceHandle No information available.
long numUPts No information available.
long numVPts No information available.
short uDegree No information available.
short vDegree No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009