VCOM:VectorWorks:ISDK::CreateImageProp

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Create an image prop from the options specified. The texture resource and optional symbol created will use names derived from the propName parameter. If those names are being used then unique names will be assigned. If enforceImageAspectRatio is true, the prop width will be derived from the prop height and the texture's image aspect ratio. Otherwise the height and width can be set independently of the texture's image aspect ratio.

virtual MCObjectHandle CreateImageProp(
const TXString& propName,
InternalIndex textureRef,
WorldCoord height,
WorldCoord width,
bool enforceImageAspectRatio,
bool crossedPlanes,
bool createPlugin,
bool autoRotate,
bool createSymbol)

Parameters

constTXString& propName No information available.
InternalIndex textureRef No information available.
WorldCoord height No information available.
WorldCoord width No information available.
bool enforceImageAspectRatio No information available.
bool crossedPlanes No information available.
bool createPlugin No information available.
bool autoRotate No information available.
bool createSymbol No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009