VCOM:VectorWorks:ISDK::CreateExtrude

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates and returns a handle to a new extrude entity. You may add objects to the definition either by using AddObjectToContainer, InsertObjectBefore, or InsertObjectAfter or by calling EnterContainer on the returned handle. [See the manual entries for these functions for more details.]. The extrude matrix defaults to the identity matrix (top view, no rotation).

virtual MCObjectHandle CreateExtrude(
WorldCoord bottom,
WorldCoord top)

Parameters

WorldCoord bottom No information available.
WorldCoord top No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009