VCOM:VectorWorks:ISDK::CreateCustomObjectPath

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates an instance of the path custom object specified by the name argument using location and angle. Calls DefineCustomObject() first to either find the defining FormatNode or create it. If it is created, the user will be presented with an initialization dialog. Returns handle to Object.

virtual MCObjectHandle CreateCustomObjectPath(
const InternalName name,
MCObjectHandle pathHand = NULL,
MCObjectHandle profileGroupHand = NULL)

Parameters

constInternalName name No information available.
MCObjectHandlepathHand= NULL No information available.
MCObjectHandleprofileGroupHand= NULL No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009