VCOM:VectorWorks:ISDK::CreateCustomObjectByMatrix

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates an instance of the CustomObject specified by the name argument. Location and orientation are defined by the matrix argument. Calls DefineCustomObject() first to either find the defining FormatNode or create it. If it is created, the user will be presented with an initialization dialog. Returns handle to Object.

virtual MCObjectHandle CreateCustomObjectByMatrix(
const InternalName name,
const TransformMatrix& matrix)

Parameters

const InternalName name No information available.
const TransformMatrix& matrix No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009