VCOM:VectorWorks:ISDK::CreateCustomObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates an instance of the custom object specified by the name argument using location and angle. Custom Object tools typically call this function with the current cursor location. Calls DefineCustomObject() first to either find the defining FormatNode or create it. If it is created, the user will be presented with an initialization dialog. Returns handle to Object.

virtual MCObjectHandle CreateCustomObject(
const InternalName name,
const WorldPt& location,
double_param angle = 0.0)

Parameters

constInternalName name No information available.
constWorldPt& location No information available.
double_param angle=0.0 No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009