VCOM:VectorWorks:ISDK::CreateConstraintModel

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This creates a parametric constraint model. It should be called efore objects which could have parametric constraints have their geometry or location modified. If all of the selected objects in the drawing will be modified, useSelection should be true. Then all selected objects will be added to the model, along with any other objects constrained to them and the involved constraints. The identified object will also be added to the model, along with any objects constrained to it. If only selected objects will be modified, obj should be nil and useSelection true. Additional objects can be added to the model with the AddToConstraintModel function.

virtual void CreateConstraintModel(
MCObjectHandle obj,
bool useSelection)

Parameters

MCObjectHandle obj No information available.
bool useSelection No information available.

Version

Availability: from Vectorworks 2009