VCOM:VectorWorks:ISDK::ConvertToPolygon

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates and returns a handle to a new polygon object which is h converted to a polygon. By default, the new polygonized object replaces the original, but if preserveOriginal is true, the polygonized object is created as the frontmost object. Note that not all objects can be converted to a polygon, so the type of the object returned may not be polyNode. In particular, lines, loci, text, bitmaps, picts, and on-drawing worksheets are not converted. Symbols and groups are converted to groups of polygonized objects.

virtual MCObjectHandle ConvertToPolygon(
MCObjectHandle h,
bool preserveOriginal = false)

Parameters

MCObjectHandle h No information available.
boolpreserveOriginal= false No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009