VCOM:VectorWorks:ISDK::BuildResourceList

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a list of information of all the resources of the specified type in the current document. If the Display Default Content preference is on and folderIndex is not 0, it will also include all the resources of the specified type in all the files in the specified folder. The folderIndex indicates a standard VW folder. subFolderName is the name of a folder in the standard folder, and it can also be a partial path. If subFolderName is empty, it will use the standard folder indicated by folderIndex. It returns an ID for the list and sets the numItems parameter.

virtual long BuildResourceList(
short objectType,
FolderSpecifier folderIndex,
const TXString& subFolderName,
long& numItems)

Parameters

short objectType No information available.
FolderSpecifier folderIndex No information available.
constTXString& subFolderName No information available.
long& numItems No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009