VCOM:VectorWorks:ISDK::AppendWidget

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Appends a widget onto the Object Info Palette for an event-enabled plug-in object. Possible widgetType values are 12 (button), and 13 (static text). EventID is the data value included in an event generated by this widget. data is unused.

virtual bool AppendWidget(
long ObjectID,
int widgetType,
int eventID,
const TXString& text,
long data)

Parameters

long ObjectID No information available.
int widgetType No information available.
int eventID No information available.
constTXString& text No information available.
long data No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009