VCOM:VectorWorks:ISDK::AlignBottomEdge

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the bottomID for the srcItem. The bottomID can be any number. All items with the same bottomID will be aligned along their bottom edge.


alignMode = eResize = 0 resize the item to align the edge

alignMode = eShift = 1 shift the item to align the edge

virtual bool AlignBottomEdge(
long dialogID,
long srcItemID,
short bottomID,
short alignMode = 1)

Parameters

long dialogID No information available.
long srcItemID No information available.
short bottomID No information available.
shortalignMode= 1 No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009