VCOM:VectorWorks:ISDK::AddVertex

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Adds p as the new last vertex in the polyline or polygon h. The vertex will be of type t. h will be transformed into a polyline if necessary. If t is vtArc, the radius of the corner is specified by arcRadius; if arcRadius is zero, the arc will be made as large as will fit. If recalcBounds is false, the bounding box of the poly is not recalculated to reflect the changed coordinate values. This is useful when you are changing many points of a polygon (call ResetObject when you have finished).

virtual void AddVertex(
MCObjectHandle h,
const WorldPt& p,
VertexType t = vtCorner,
WorldCoord arcRadius = 0,
bool recalcBounds = true)

Parameters

MCObjectHandle h No information available.
const WorldPt& p No information available.
VertexType t No information available.
WorldCoord arcRadius No information available.
bool recalcBounds No information available.

Version

Availability: from Vectorworks 2009