VCOM:VectorWorks:ISDK::AddClass

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Adds a new class with the name specified and returns its classID index. If a class of that name already exists, the function does nothing and returns the existing class index.

virtual InternalIndex AddClass(
const InternalName className)

Parameters

constInternalName className No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009