VCOM:VectorWorks:ISDK::AddAfterMoveObject

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Use this callback after you move an object in your routine. "Move" here does not mean moving an object across the page (like a drag), it means moving an object within the internal MiniCad main drawing list (like when an object changes layers or is "sent to back"). Only applicable after a SetUndoMethod(cbp, kUndoSwapObjects) or a SetUndoMethod(cbp, kUndoReplaceSelection) call has been made. An AddBeforeMoveObject(h) must have been called before AddAfterMoveObject(h) is called. Passing a nil handle creates undo primitives for all selected objects.

virtual bool AddAfterMoveObject(
MCObjectHandle h)

Parameters

MCObjectHandle h No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009