VCOM:VectorWorks:IFCLib:IIFCSupport::WS FillCOBieFixedWorksheets

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Automatically fills a worksheet with COBie data, provided the correct worksheet handle is given. See Remarks for further information.

VCOMError WS_FillCOBieFixedWorksheets(
MCObjectHandle worksheet,
bool bIsRolledUp);

Parameters

worksheet MCObjectHandle Handle to worksheet
bIsRolledUp bool Parameter is not used. Set to True.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

This function can fill 10 designated worksheets with COBie data. In order to get an accurate COBie worksheet a correct handle to a preformatted worksheet must be provided. It can be called for the following preformatted reports:


  • COBieContact Worksheet
  • COBieContact Help Worksheet
  • COBieFacility Worksheet
  • COBieFacility Help Worksheet
  • COBieFloor Worksheet
  • COBieFloor Help Worksheet
  • COBieAttribute Worksheet
  • COBieAttribute Help Worksheet
  • COBieSystem Worksheet
  • COBieSystem Help Worksheet


The worksheets can be found in the Vectorworks default content in the following location: Defaults >> Reports_Schedules >> COBie.vwx .

In order to fully understand what COBie is and how the COBie worksheet are structured, please follow the links:

COBie

COBie Responsibility Matrix


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.