VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetPsetName

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Returns the name of the Property Set (SPet).

VCOMError IFC_GetPsetName(
MCObjectHandle hObject,
short index,
TXString& strIfcPsetName);

Parameters

hObject MCObjectHandle Handle to the object.
index short Index of the attached PSet.
strIfcPsetName TXString Out parameter, the name of the PSet.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2009