VCOM:VectorWorks:IFCLib:IIFCSupport::IFC GetFieldsCount

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

If the object do not uses Data Mapping, the function returns kVCOMError_Failed. Otherwise the function returns the number of fields which are mapped.

VCOMError IFC_GetFieldsCount(
const TXString& strObjectName,
const TXString& strEntryName,
short& outCount);

Parameters

strObjectName TXString The name of the object.
strEntryName TXString The name of the entity/pset.
outCount short The result - count of mapped fields.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2017.