VCOM:VectorWorks:IFCLib:IIFCSupport::IFC AddField

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Adds a new field to the specified entry or Pset.

VCOMError IFC_AddField(
const TXString& strObjectName,
const TXString& strEntryName,
const TXString& strFieldName,
const short& type,
bool bOptional,
bool bEnable,
bool bEmpty,
const TXString& strPSetName = "");

Parameters

strObjectName TXString Object name.
strEntryName TXString Ifc entity name.
strFieldName TXString Field name.
type short Field type. Possible values are represented by EIfcType
bOptional bool Boolean that determines whether the field is optional or mandatory.
bEnable bool Boolean that determines whether the field is enabled or disabled.
bEmpty bool Boolean that determines whether the field is empty.
strPSetName TXString Property set name. The default value for this parameter is empty string. Only add this parameter if the field is to be added to this property set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2019.