VCOM:VectorWorks:Filing:IStdFile::SeekForward
Jump to navigation
Jump to search
.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference
Description
namespace VectorWorks::Filing
Member of VCOM:VectorWorks:Filing:IStdFile
Moves forward (toward the file end) the current file read/write position with the specified offset.
virtual VCOMError VCOM_CALLTYPE SeekForward(
Uint64 offset) = 0;
Parameters
offset Uint64 Offset in which the current file read/write position should be moved.
Return Value
Uses standard VCOM Error Reporting.
Return value meaning:
kVCOMError_NotInitialized Bad VCOM instance used to call the fuction. kVCOMError_Failed Routine failed.
See Also
VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IStdFile
[[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IStdFile]]